Jump to content
Sign in to follow this  
my hounds

Lamp/Light Question

Recommended Posts

1 hour ago, poxon said:

I don’t get on with led stuff the lights to clear for my eyes I struggle to spot stuff 

Seen 

  • Haha 1

Share this post


Link to post

22 minutes ago, Black neck said:

Fair 3 mate 

Pictures were taken for memories, not testing the lamp. my lamp was a lot tighter, her was opened slightly and variable, not sure if she had it full on? but a reference for the lad that asked. Its all i need ATB

Share this post


Link to post
6 hours ago, my hounds said:

The Light Force L140 comes with a 75 watt bulb has any one replaced it with a 100 watt bulb I realise it will be brighter due to the 25 watt difference,my question is does it throw a longer beam and is it noticeable,cheers.

Put a 100 watt bulb in a 140 many of times sweet as long as you don’t have it on to long atb longers01 

Share this post


Link to post
38 minutes ago, spanielsandhawks said:

Pictures were taken for memories, not testing the lamp. my lamp was a lot tighter, her was opened slightly and variable, not sure if she had it full on? but a reference for the lad that asked. Its all i need ATB

Good man there

  • Like 1

Share this post


Link to post
20 hours ago, longers01 said:

Put a 100 watt bulb in a 140 many of times sweet as long as you don’t have it on to long atb longers01 

That's one of my thoughts/questions if the lamp is on how longs "too long",what have you experienced?,atb.

Share this post


Link to post

I was using a 140 with a 100 watt bulb in for little bits and bobs ( airgun) and it has been fine so far (admittedly not used as much as I used to,no dog in this season) I've just lined my Greyhound with a mates Deerhound so fingers crossed. I also use a cut down filter that's painted black to tighten the beam up on my Lightforce lamps except the Blitz to stop as much overspill. Hopefully I will use the 140 with a thermal so the lamp will be used a lot less than in the past anyway.The 140 lamp came to me off a mate and it also had a black spot in the middle of the beam,I tried a few different bulbs but it did not cure it ?? I then sussed out that there was a snot on the front of the poly lens cover right in the centre so I sanded it off with different grades of wet/dry nothing to heavy just light enough to be removing the snot and then once the snot was removed I polished the area with a Dremel with a polishing mop in it and toothpaste and it worked a treat. Ive used all sorts of lamps over the years from home made to  Clulite to all the different Lightforce range and also led which I just could not get on with. hth 

IMG_3300.JPG

Edited by MickC

Share this post


Link to post
21 hours ago, my hounds said:

That's one of my thoughts/questions if the lamp is on how longs "too long",what have you experienced?,atb.

I left my 170 in the boot one night and it was accidentally left on all night till battery ran out,it left a little bronze mark on the reflector but it did not effect the lamp at all.  I suppose it could of been worse if the battery was fully charged but it had been used  that night before being left on.

Share this post


Link to post
20 hours ago, MickC said:

I left my 170 in the boot one night and it was accidentally left on all night till battery ran out,it left a little bronze mark on the reflector but it did not effect the lamp at all.  I suppose it could of been worse if the battery was fully charged but it had been used  that night before being left on.

MickC sent you a PM,atb My Hounds.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...